Subject: [Thuban-list] Apply wxInitAllImageHandlers?

From: Jan-Oliver Wagner <[email-masked]>
Date: Tue, 23 Sep 2003 09:55:04 +0200

Hi,

I wonder whether Thuban should always call
wxInitAllImageHandlers() at startup to make JPEG and
other formats available for wxBitmap.

Any particular reason why this should better not be done?

	Jan

-- 
Jan-Oliver Wagner               http://intevation.de/~jan/

Intevation GmbH	              	     http://intevation.de/
FreeGIS	                               http://freegis.org/

---

From: Bernhard Herzog <[email-masked]>
Date: Tue, 07 Oct 2003 19:45:24 +0200

> Any particular reason why this should better not be done?

The only reason that comes to mind is that it will delay startup a bit
and probably increase memory consumption.

   Bernhard

-- 
Intevation GmbH                                 http://intevation.de/
Sketch                                 http://sketch.sourceforge.net/
Thuban                                  http://thuban.intevation.org/

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Wed, 8 Oct 2003 10:19:01 +0200

> and probably increase memory consumption.

any estimates for this available?

In general, I think it is a good idea since the various formats
needs more and more to be dealt with anyway.
So, if the delay and mem consumption is not significant, I propose
to apply the initialiazation.

Best

	Jan

---

From: Bernhard Herzog <[email-masked]>
Date: Wed, 08 Oct 2003 10:40:13 +0200

> any estimates for this available?

The change only involves adding the wxInitAllImageHandlers call to the
app's OnInit method, I guess, so it shouldn't take more than a few
minutes.

  Bernhard