Subject: [Thuban-list] How to start Thuban?

From: James Cameron <[email-masked]>
Date: Thu, 25 Apr 2002 22:17:22 +1000

G'day,

I've just downloaded Thuban and built it successfully on Debian
GNU/Linux woody.  I needed to install the following additional packages
before the build worked;

	libwxgtk2.2-dev 
	libwxbase2.2-dev
	python-dev 
	libwxgtk2.2-python

But I cannot work out how to actually run it.
(Reply-To set to me, I've not joined the list yet.)

What I did ...

   python setup.py build
   python setup.py install_local

Then ...

quozl:/usr/local/src/Thuban-0.1.1$ find . -name thuban
./extensions/thuban
quozl:/usr/local/src/Thuban-0.1.1$ ./extensions/thuban
bash: ./extensions/thuban: is a directory
quozl:/usr/local/src/Thuban-0.1.1$ find . -name Thuban
./Thuban
./build/lib.linux-i686-2.1/Thuban
quozl:/usr/local/src/Thuban-0.1.1$ ./Thuban
bash: ./Thuban: is a directory
quozl:/usr/local/src/Thuban-0.1.1$ ./build/lib.linux-i686-2.1/Thuban
bash: ./build/lib.linux-i686-2.1/Thuban: is a directory
quozl:/usr/local/src/Thuban-0.1.1$ python thuban.py 
Traceback (most recent call last):
  File "thuban.py", line 20, in ?
    import Thuban.UI.main
  File "Thuban/UI/main.py", line 33, in ?
    from application import ThubanApplication
  File "Thuban/UI/application.py", line 20, in ?
    from Thuban.Model.load import load_session
  File "Thuban/Model/load.py", line 39, in ?
    import xml.sax
ImportError: No module named xml.sax
quozl:/usr/local/src/Thuban-0.1.1$ 

I suggest the README be adjusted.
I checked the mailing list archives.

-- 
James Cameron    mailto:[email-masked]     http://quozl.netrek.org/

---

From: Bernhard Reiter <[email-masked]>
Date: Thu, 25 Apr 2002 17:29:00 +0200

> ImportError: No module named xml.sax

You probably need another Debian package:
	python2.2-xml 
Debian is separating python packages further.

> I suggest the README be adjusted.

Yes, good call.  
Thanks for the feedback.