Subject: Re: [Thuban-list] thuban very slow on low-end machine

From: "Moritz Lennert" <[email-masked]>
Date: Sun, 6 Jul 2003 10:24:58 +0200 (CEST)

Tracy Love said:
> I dont mean to be rude but 150mhz isnt going to be fast with any gis work.

No offense taken, I know the machine is (very) low-end, but some reactions
just don't seem normal to me.

For example: when I open Thuban, without any maps loaded, yet, and I then
just move my mouse pointer back and forth over the Thuban screen, CPU
usage goes up to over 90%. As a comparison, doing the same in Sketch or
Mozilla, never pushes CPU over 30%.

Also, if I understand correctly Thuban is supposed to be a viewer, not a GIS.

Moritz

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Sun, 6 Jul 2003 12:47:37 +0200

> Also, if I understand correctly Thuban is supposed to be a viewer, not a GIS.

It is currently primarily a viewer. Thuban intends to interconnect
with various other Free GIS Software (so far gdal, shapelib and
proj). It might be interesting to connect Thuban to real GIS like
GRASS.

In order to support the connectivity, Thuban is designed to be
very flexible, eg. extensible with modules.

	Jan
-- 
Jan-Oliver Wagner               http://intevation.de/~jan/

Intevation GmbH	              	     http://intevation.de/
FreeGIS	                               http://freegis.org/

---

From: Bernhard Reiter <[email-masked]>
Date: Sun, 6 Jul 2003 19:50:13 +0200

> just don't seem normal to me.

We did not test it on such a machine, yet
and Thuban is also not optimised for speed so far.

I'be been running Thunban on a Pentium II 200Mhz also with 120MB
booting from a Free Software Knoppix-CD 
and it was a bit slow, but usable.

> Mozilla, never pushes CPU over 30%.

In any way thanks for the report.
Can you give us more details about the system and about the version
of Thuban and the library you are using ( check the About dialog for
a start)?
It would be also interesting to see the memory consumption.

> Also, if I understand correctly Thuban is supposed to be a viewer, not a GIS.

Correct.

---

From: "Moritz Lennert" <[email-masked]>
Date: Mon, 7 Jul 2003 13:31:30 +0200 (CEST)

> It would be also interesting to see the memory consumption.

Here's the About dialog (I don't know about the GDAL - not available
message, I installed the unofficial Debian packages of GDAL as available
from the Thuban download page.):

Thuban Release Version 0.8.1

Currently using:
	wxPython 2.4.0.7
	Python 2.2.2
	PySQLite 0.4.3
	SQLite 2.8.2
	GDAL - not available

Compiled against:
	GTK 1.2.10
	proj 4.4.7

I've been testing this config on a better machine today (Intel(R)
Pentium(R) 4 CPU 1.80GHz, and 512MB RAM), and obviously Thuban is much
faster and quite usable. However, I still get high CPU usage (up to over
60%) by just moving the mouse back and forth over an empty session. Memory
usage stays quite low (less than 5%, even when playing around with a >
20.000 polygon shape file), but I'll check that with my old machine when I
have the time.

Moritz