Subject: [Thuban-list] Errors on Thuban 1.0rc1

From: Maurizio Napolitano <[email-masked]>
Date: Tue, 23 Dec 2003 11:29:38 +0100

I have compiled the wxwindows  and the wxPython package on
my laptop (before i have used the RPM made for Mandrake) and
now i have resolved the problem to load a ESRI Shape file 
(before this operation Thuban went in crash).

Now i have others problems :(
The first is by use the command "Projections" under the menu
"Map".
The errors is very "crazy": my XFree go in crash!!!
Probably i need to compile the proj libraries from the sources
without use the RPM package for Mandrake.

The second i always the problem to use the "Classification"
to display a layer.
I go to the properties of a layer and the label "Classification"
is disable.
On the right of the label "Field" the space i "white" but,
if i go on the right of the label with the mouse and double
click the program show me the combobox with the all fields.
Why?

Look this pictures (in italian language) to understand my
problems.
http://sra.itc.it/people/napolitano/images/Errore1.png
http://sra.itc.it/people/napolitano/images/Errore2.png

PS: i can select the field but ... i can't change the draw
of the layer

---

From: Bernhard Herzog <[email-masked]>
Date: Tue, 23 Dec 2003 12:51:47 +0100

Maurizio Napolitano <[email-masked]> writes:

> my laptop

Which version?
Did you use any unusual configure options?  I've used

../configure --with-gtk --prefix=$INSTALL_PREFIX --enable-debug --enable-debug_gdb --enable-resources --enable-prologio

> http://sra.itc.it/people/napolitano/images/Errore2.png

You seem to be using a non-standard theme.  IIRC wxGTK has (or at least
used to have) problems with theme engines, so maybe that is part of the
problem.  Which theme are you using?  I've just tested Thuban with a few
theme engines but I didn't see any problems so far.

  Bernhard

-- 
Intevation GmbH                                 http://intevation.de/
Sketch                                 http://sketch.sourceforge.net/
Thuban                                  http://thuban.intevation.org/