Subject: Re: [Thuban-list] Some bugs on Mac OS X

From: Lorenzo Moretti <[email-masked]>
Date: Tue, 21 Dec 2004 12:11:32 +0100

Hi Bernhard

Bernhard wrote
>
>It is related to wxwidgets then, because the toolbar is not displayed
>like in other ports (gtk, windows).
>Hmmm, I think you should also submit a report about this problem.

OK

>  >    Thuban 1.1 cvs-20041219
>>     Currently using:
>>             wxPython 2.4.2.4
>>             Python 2.3.0
>>         PySQLite 0.5.1
>>       SQLite 2.8.15
>>        GDAL 1.2.5.0
>>
>>             psycopg 1.1.14
>>     Compiled for:
>>          GTK - not available
>
>Obviously no GTK. ;)
>
>>             proj 4.4.9
>>
>>     Extensions:
>>
>>             None registered.
>
>This is strange you should have a few Extensions.
>Or how did you use svgexport? ;)

I've created thubanstart.py inside $HOME/.thuban folder and I have tested:

Doesn't work
-------------
export PYTHONPATH="/usr/local/lib/thuban/Extensions"

Doesn't work
-------------
import sys
sys.path.append("/usr/local/lib/thuban/Extensions/")

Works
-----
I import all extensions:

....
import bboxdump
import drawshape
import gns2shp
import apr
....

This method works but it's difficult.
Another way?

>  >      >    Printing from Thuban.
>
>>     I have produced a Thuban SVG file: it's OK but the lines are very big,
>>     more than 1 point. OK I can change them in my vector program but
>>     perhaps it's possible to write a smaller size in SVG plugin.
>
>Change the following line in Extensions/svgexport/svgmapwriter.py:
>	            self.pen["stroke-width"] = pen.GetWidth()
>You might even comment it out.

Wow..
Now the SVG output is fantastic, really good.
This line can be uncommented in CVS or no?

>
>Best,
>	Bernhard
>
>Attachment converted: APPLI:Untitled 74 (    /    ) (004171EA)
>_______________________________________________
>Thuban-list mailing list
>[email-masked]
>https://intevation.de/mailman/listinfo/thuban-list

-- 
________________________________________________________________________
||      Lorenzo Moretti        e-mail: [email-masked]     
||/|/|  ENEA prot/idr          Web: http://wwwamb.bologna.enea.it/    
||   |  via Don Fiammelli, 2   FTP: ftp://ftpamb.bologna.enea.it/ (ris.)
~~~~~~  40128 BOLOGNA - ITALY  Ph: +39-0516098086  Fax: +39-0516098131
________________________________________________________________________

---

From: Bernhard Herzog <[email-masked]>
Date: Tue, 21 Dec 2004 12:25:13 +0100

> import apr

Just

import Extensions.gns2shp
...

should be enough without any PYTHONPATH or sys.path manipulations.

drawshape is very experimental, BTW.  make sure you read its README file
before doing anything with it.

   Bernhard

-- 
Intevation GmbH                                 http://intevation.de/
Skencil                                           http://skencil.org/
Thuban                                  http://thuban.intevation.org/

---

From: Bernhard Reiter <[email-masked]>
Date: Tue, 21 Dec 2004 12:32:16 +0100

Hi Lorenzo,

> >Hmmm, I think you should also submit a report about this problem.

Thanks in advance.

> This line can be uncommented in CVS or no?

The problem with taking the line out is that if you have
changed the line types with a classification, you will not see
a difference in line lenght anymore. I have to think about how
to solve this best. I might make this an option to the extension
then the user could decide in the future.

	Bernhard R.

---

From: "Moritz Lennert" <[email-masked]>
Date: Tue, 21 Dec 2004 13:30:43 +0100 (CET)

> then the user could decide in the future.

I imagine we are talking about line width, or ?

Funny, I cannot reproduce Lorenzo's problem. But at the same time, I seem to
have the opposite one: line width is always the same (1) in the svg file (at
least as it is read by sketch 0.6.15 on Debian) whatever its value in Thuban.

Am I misunderstanding the issue, or is there a bug ?

Moritz

---

From: Bernhard Reiter <[email-masked]>
Date: Thu, 23 Dec 2004 17:53:14 +0100

> >> >>    I have produced a Thuban SVG file: it's OK but the lines
> >> >>    are very big, more than 1 point. OK I can change them in
> >> >>    my vector program but perhaps it's possible to write a
> >> >>    smaller size in SVG plugin.
> >> >

Of course. Sorry for that.

> Am I misunderstanding the issue, or is there a bug ?

There probably are bugs in the code.
What version of Thuban are you using?

	Bernhard

---

From: Bernhard Reiter <[email-masked]>
Date: Mon, 27 Dec 2004 17:07:42 +0100

> > line width is always the same (1) in the svg file (at

Hi Moritz,

I cannot reproduce this problem:

svgexport 1.0.0 
Thuban CVS current.
Skencil 0.6.15, 0.6.16 and 0.7. CVS.

	Used the iceland_sample_class.thuban
	and gave the blue lines width 2 and the green ones width 3.
	Also gave the farm circles a size three orange border line.

	Wrote out the map in Thuban-Map-SVG.
	Opened in skencil, ungrouped the objects enough
	and checked the line dialog to see that the width was different.
	
	Zooming in on a place where black, blue and green lines are
	close to each other also makes the difference visible.

	Opening the svg file with an editor I see that 
	stroke-width: has the right proportions to each other.

Can you try to zoon in and recheck?

Bernhard R.

---

From: "Moritz Lennert" <[email-masked]>
Date: Mon, 3 Jan 2005 11:17:35 +0100 (CET)

Hi Bernhard,

> Can you try to zoon in and recheck?

You are absolutely right. Sorry, I didn't check this enough before posting my
"bug". (IIRC, I didn't ungroup.)

Moritz