Subject: [Thuban-list] can't run thuban on windows xp

From: "laurent.caron.1" <[email-masked]>
Date: Tue, 17 Jan 2006 19:00:29 +0100

Hello,

I tried to run thuban on my windows xp and it doesn't work.

I used win32 install and thuban was install on c:\programe files\thuban  
rep and my python was on c :\python24 rep.

I installed all requiered lib

if i tried to run thuban using begin/thuban/start thuban, he said :  
pythonw.exe dont find, this application can't start to due not found 
python23.dll. resinstall application can solve problem.

Then i run the idle python module and i load thuban.pyw file on

#!c:\python24\python.exe ( i change this to indicate my python folder )

# Copyright (c) 2001 by Intevation GmbH
# Authors:
# Bernhard Herzog <[email-masked]>
#
# This program is free software under the GPL (>=v2)
# Read the file COPYING coming with Thuban for details.

import sys, os
import Thuban

# Put the Lib dir into the path. The Lib dir contains some extra non
# really Thuban specific Python modules
thubandir = os.path.join(Thuban.__path__[0], '..')
dir = os.path.join(thubandir, "Lib")
if os.path.isdir(dir):
    sys.path.insert(0, dir)

import Thuban.UI.main
   
# Start Thuban
Thuban.UI.main.main()

WHen i run, i ve got this message :

Traceback (most recent call last):
  File "C:\Program Files\Thuban\thuban.pyw", line 20, in -toplevel-
    import Thuban.UI.main
  File "C:\Program Files\Thuban\Thuban\UI\main.py", line 18, in -toplevel-
    from application import ThubanApplication
  File "C:\Program Files\Thuban\Thuban\UI\application.py", line 26, in 
-toplevel-
    from Thuban.Model.session import create_empty_session
  File "C:\Program Files\Thuban\Thuban\Model\session.py", line 25, in 
-toplevel-
    from data import ShapefileStore
  File "C:\Program Files\Thuban\Thuban\Model\data.py", line 20, in 
-toplevel-
    import shapelib
  File "C:\Program Files\Thuban\Thuban\..\Lib\shapelib.py", line 2, in 
-toplevel-
    import shapelibc
ImportError: DLL load failed: Le module spécifié est introuvable.

What can i do to run this program i want try, thx

lo

---

From: Moritz Lennert <[email-masked]>
Date: Wed, 18 Jan 2006 11:38:23 +0100

> python23.dll. resinstall application can solve problem.

If I am not mistaking, Thuban needs python23, not python24, as is said 
on the download page:

Required:
Python 2.3.4
wxPython 2.4.2.4 for Python 2.3

Moritz

> ------------------------------------------------------------------------
> 
> _______________________________________________
> Thuban-list mailing list
> [email-masked]
> https://intevation.de/mailman/listinfo/thuban-list