Subject: [Thuban-list] Python version mismatch in Debian "testing":

From: "Roger André" <[email-masked]>
Date: Mon, 15 May 2006 18:13:01 -0700

I just tried to apt-get Thuban in Debian and after all the loading was done
and I tried to run it, I got the following error:
*******************************************************
 The following version errors were detected:
     Thuban was compiled with wx 2.4.4 but wxPython is 2.4.5.0
*********************************************************

Has anyone else run into this before? I'm running Knoppix 3.9 in a HD
installation.

---

From: Didrik Pinte <[email-masked]>
Date: Tue, 16 May 2006 07:50:25 +0200

Le lundi 15 mai 2006 à 18:13 -0700, Roger André a écrit :
> I just tried to apt-get Thuban in Debian and after all the loading was
> done and I tried to run it, I got the following error:
> ___________________

Hi Roger,

The message is pretty clear. Some extensions of Thuban are compiled and
thus linked with specific version of external libraries like wxPython. 

The solution is to use a source version of thuban and compile it
yourself or use another compiled package but made for your distribution.

Didrik

---

From: Bernhard Reiter <[email-masked]>
Date: Tue, 16 May 2006 10:01:28 +0200

Am 16. May 2006 um 07:50:25 schrieb Didrik Pinte:
> > done 

Which version of thuban did you actually get?
Was it 1.1.0-1 from experimental?

> > and I tried to run it, I got the following error:

If it was from experimental, this might be a temporary problem.
You should report it though to the Debian Bug-Tracker using "reportbug thuban".

> thus linked with specific version of external libraries like wxPython. 

Which would be a bug in the build or dependencies of the Debian package.

> yourself or use another compiled package but made for your distribution.

You could try building the source version from Debian
	apt-get source thuban
	apt-get build-dep thuban
	cd thuban-1.1.0
	fakeroot debian/rules binary