Subject: [Thuban-list] creating new/updated epsg projection list

From: Moritz Lennert <[email-masked]>
Date: Wed, 29 Jun 2005 15:25:48 +0200

Hello,

I need a projection which is not in Thuban's epsg list (epsg 3035),
but it is in the list that comes with Debian testing proj. However,
the later is in the following format:

# ETRS89 / ETRS-LAEA
<3035> +proj=laea +lat_0=52 +lon_0=10 +x_0=4321000 +y_0=3210000
+ellps=GRS80 +units=m +no_defs  <>

I can obviously retype the info by hand and then export this into a
custom projections file, but I was wondering :

- - whether someone had a script which translates the proj format into
the thuban xml format
- - whether it might be possible / desirable to create a direct access
to the proj epsg file, i.e. to use this format instead of / in
addition to the thuban xml format
- - why the thuban epsg file contains less projections (is it
outdated ?)
- - if it is outdated, what is the policy for updating it in Thuban
cvs ?

Moritz

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Wed, 29 Jun 2005 23:43:32 +0200

Hi Moritz,

On Wed, Jun 29, 2005 at 03:25:48PM +0200, Moritz Lennert wrote:
> but it is in the list that comes with Debian testing proj.

probably it uses a newer EPSG version.

> However, the later is in the following format:
> 
> # ETRS89 / ETRS-LAEA

of course, I did not convert the stuff manually. :-)
See thuban/devtools/create_epsg.py

> addition to the thuban xml format

this could be implemented indeed. On GNU/Linux, the file
should always be /usr/share/proj/epsg
but on Windows it might be anywhere else. So, in case
someone wants to implement it, it should be additional
rather than instead of.

> - - why the thuban epsg file contains less projections (is it

it probably uses the set of an older EPSG version.

> - - if it is outdated, what is the policy for updating it in Thuban

well, here is point where it hurts. In fact EPSG is crap because
the occasionally drop entries with a new version. Thats why
we have the epsg-deprecated.proj file in Resources.
Updating should thus mean to analyse which codes are dropped
and then add them to the deprecated list.
Why is this important? OGC unfortunately decided to rely on
EPSG for SRS and thus some WMS servers might use EPSG codes
your new proj does not know anymore :-(
This happened e.g. for the Gauss-Krüger where I live (Osnabrück).

Of course, from time to time it makes sense to updated the epsg.proj
file!

Best

	Jan
-- 
Jan-Oliver Wagner               http://intevation.de/~jan/
Intevation GmbH                      http://intevation.de/
Kolab Konsortium               http://kolab-konsortium.de/
FreeGIS                                http://freegis.org/