Subject: [Thuban-list] linking wxproj

From: "nym" <[email-masked]>
Date: Tue, 18 Jun 2002 11:20:09 -0500

This is a blocker to running thuban on my system.

[localhost:~/thuban] nym% python thuban.py 
09:14:30: Debug: /usr/local/lib/libwx_macd-2.3.rsrc
Traceback (most recent call last):
  File "thuban.py", line 20, in ?
    import Thuban.UI.main
  File "Thuban/UI/main.py", line 41, in ?
    from application import ThubanApplication
  File "Thuban/UI/application.py", line 26, in ?
    import view
  File "Thuban/UI/view.py", line 23, in ?
    from wxproj import point_in_polygon_shape, shape_centroid
ImportError: Failure linking new module

i have wxproj.so in /usr/local/thuban/Lib/ btw.

Sincerely,
Nym

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Thu, 20 Jun 2002 09:08:51 +0200

Hi,

from your later email I read that you are actually on a
MacOS X system which we don't have available for testing.
However, you seem to have solved the issue. If so,
can you leave a note here for the archives on what
the problem was?

> i have wxproj.so in /usr/local/thuban/Lib/ btw.

Best

	Jan

-- 
Jan-Oliver Wagner               http://intevation.de/~jan/

Intevation GmbH	              	     http://intevation.de/
FreeGIS	                               http://freegis.org/