Subject: Re: [Thuban-list] [Thuban-announce] Thuban development release 1.1.0

From: "Serviopa" <[email-masked]>
Date: Thu, 14 Jul 2005 21:46:10 -0300

I've compilded it in Mandriva 2005 LE with wxPython 2.6.1. When I try to
start
it, I get this error:

Traceback (most recent call last):
File "/usr/local/bin/thuban", line 20, in ?
import Thuban.UI.main
File "/usr/local/lib/thuban/Thuban/UI/main.py", line 18, in ?
from application import ThubanApplication
File "/usr/local/lib/thuban/Thuban/UI/application.py", line 35, in ?
import view
File "/usr/local//lib/thuban/Thuban/UI/view.py", line 41, in ?
from renderer import ScreenRenderer, ExportRenderer, PrinterRenderer
File "/usr/local//lib/thuban/Thuban/UI/renderer.py", line 35, in ?
from Thuban.UI.classifier import ClassDataPreviewer
File "/usr/local//lib/thuban/Thuban/UI/classifier.py", line 41, in ?
from Thuban.UI.classgen import ClassGenDialog
File "/usr/local/lib/thuban/Thuban/UI/classgen.py", line 43, in ?
GENCOMBOSTR_UNIFORM = _("Uniform Distribution")
File "/usr/local//lib/thuban/Thuban/__init__.py", line 56, in _
return _translation_function(s)
File "/usr/local//lib/thuban/Thuban/UI/__init__.py", line 38, in
thuban_wx_translation
t = t.encode(Thuban._internal_encoding, "replace")
LookupError: unknown encoding: pt_pt

My system's locale is pt_BR, not pt_pt, so why Thuban try to use pt_pt?
Also,
how to bypass it?

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Tue, 19 Jul 2005 12:53:08 +0200

> My system's locale is pt_BR, not pt_pt, so why Thuban try to use pt_pt?

does thuban show up when you enter:

$ LANG=C ./thuban.py

?

	Jan
-- 
Jan-Oliver Wagner               http://intevation.de/~jan/
Intevation GmbH                      http://intevation.de/
Kolab Konsortium               http://kolab-konsortium.de/
FreeGIS                                http://freegis.org/