Subject: Re: [Thuban-list] Further work on extensibility

From: "nym" <[email-masked]>
Date: Thu, 20 Jun 2002 18:42:04 -0500

Hey,

I'm not sure if this is the case, but is this intended to help extend 
thuban to allow objects from an application-ontop-thuban, such as 
postgis server connectivity? I'm trying to pick up as much as I can as 
quickly as possible on this, but I'm still a bit fuzzy. I'm in the process 
of going through the code to understand it all. At the moment I'm 
imagining a layer that supports dynamic objects, such as data from 
postgis. Obviously there are certain design issues at play here, and 
I'd like to know where this would best be implemented. For example, 
what about refreshing? Is this something we should do just on 
specific layers, or does it have to be done on the whole map?

Sincerely,
Tom 

-----Original Message-----
From: Jan-Oliver Wagner <[email-masked]>
To: Thuban Mailing List <[email-masked]>
Date: Thu, 20 Jun 2002 17:34:05 +0200
Subject: [Thuban-list] Further work on extensibility

> Hi,
> 
> I just checked in some further experimental code to handle
> extensions for Thuban. I introduced a new type Extension
> of which can many be part of a Scenario. An extension
> can have a list of Objects which are to be defined by your
> application-ontop-thuban.
> 
> The sample code will eventually show up as part of GREAT-ER,
> the first Thuban-extending Application.
> 
> Remind that the concept has not yet settled and is pontially
> subject to change. Discussion is welcome of course.
> 
> 	Jan
> 
> -- 
> Jan-Oliver Wagner               http://intevation.de/~jan/
> 
> Intevation GmbH	              	     http://intevation.de/
> FreeGIS	                               http://freegis.org/
> 
> _______________________________________________
> Thuban-list mailing list
> [email-masked]
> https://intevation.de/mailman/listinfo/thuban-list

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Fri, 21 Jun 2002 14:41:08 +0200

Hi Tom,

On Thu, Jun 20, 2002 at 06:42:04PM -0500, nym wrote:
> postgis server connectivity?

no, the application GREAT-ER I mentioned as an example is a simulation
system for chemicals in rivers and its functions should be kept
separate from Thuban since they are not directly related to GIS.

Features like a PostGIS connection should be an integral part
of Thuban.

> I'm trying to pick up as much as I can as 
> I'd like to know where this would best be implemented.

We are not in favour of big-design-upfront and therefore Thuban only abstracts
where it was really needed. Further abstraction should follow once
it is clear what needs to be incorporated.

For adding PostGIS I suggest you make a copy of Model/layer.py:Layer
and make it a PostGIS Layer. We can later discuss on how a base class
should look like. We'll learn a lot comparing the PostGIS
and Shapefile Layer.

Furthermore you will need to make modifications to UI/renderer.py.
Some abstraction would make sense there, so feel free to implement
something to adapt to the PostGIS layer.

You might need to sligthly modifiy UI/view.py, but this module
is already quite generic.

> For example, 

Thuban has a message system where information on changes are forwarded.
Please have a look at it.

Hope the hints help. Please don't hesitate to discuss your
implementation ideas here on this list.

All the best

	Jan