Subject: [Thuban-list] Thuban1.1.0 rpm, deb

From: <[email-masked]>
Date: Mon, 25 Jul 2005 16:05:50 +1000

Anybody manage to build and install Thuban 1.1.0?

Please post your Thuban1.1.0*.rpm or thuban1.1.0*.deb download link.

It seems that Thuban having problem to find wx/wx.h.

My installation is Ubuntu with wxpython-2.6.1.0 from src.rpm using
rpmbuild then alien. 

How could I make Thuban see my wx.h in
/usr/lib/wxPython-2.6.1.0-gtk2-unicode/include/wx-2.6/wx?

Any new thuban.spec file for thuban1.1.0?

Thanks, Noli

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Mon, 25 Jul 2005 15:00:51 +0200

Hi Noli,

> Anybody manage to build and install Thuban 1.1.0?

sure :-)

> Please post your Thuban1.1.0*.rpm or thuban1.1.0*.deb download link.

if anyone had the time to build such packages, please let us know
and we add them to the download web page.

> /usr/lib/wxPython-2.6.1.0-gtk2-unicode/include/wx-2.6/wx?

Try
$ python setup.py build_ext --use-wx-python-swig-hack  install_local

(see README file in Thuban packages for more info about this issue)

> Any new thuban.spec file for thuban1.1.0?

There is a package for 1.0.0 for Fedora here:
http://thuban.intevation.org/download.html#src_fedora_core_2
which may be a good start for 1.1.0.

All the best

	Jan
-- 
Jan-Oliver Wagner               http://intevation.de/~jan/
Intevation GmbH                      http://intevation.de/
Kolab Konsortium               http://kolab-konsortium.de/
FreeGIS                                http://freegis.org/

---

From: Bernhard Herzog <[email-masked]>
Date: Mon, 25 Jul 2005 15:22:04 +0200

> /usr/lib/wxPython-2.6.1.0-gtk2-unicode/include/wx-2.6/wx?

Is wx-config in your PATH?  Thuban's setup.py uses that to figure out
how to get the wxWidgets header files and libraries.

   Bernhard

-- 
Intevation GmbH                                 http://intevation.de/
Skencil                                           http://skencil.org/
Thuban                                  http://thuban.intevation.org/

---

From: Moritz Lennert <[email-masked]>
Date: Mon, 25 Jul 2005 15:53:01 +0200

> $ python setup.py build_ext --use-wx-python-swig-hack  install_local

For me under Debian, just going into the thuban directory and launching

fakeroot dpkg-buildpackage

works like a charm.

As far as I remember the swig hack is included in the debian rules file.

MOritz