Subject: [Thuban-list] RE: Thuban1.1.0 rpm, deb

From: <[email-masked]>
Date: Tue, 26 Jul 2005 14:42:01 +1000

Manage to get thuban working.

Using this:
python setup.py build_ext --use-wx-python-swig-hack  install_local

In (K)ubuntu using:
Python2.4.1
wxwidget2.6 from http://http.us.debian experimental, but not wxpython2.6
since no dev package
wxpython2.6.1.0 from from wxpython.org src.rpm by rpmbuild and alien

No
Python-gdal, since debian python-gdal1.2.6.1 uses <python2.4

Where could I found python-gdal 1.2.6.1 src.rpm or where do you keep
python-gdal > 1.2.5 as recommended for Thuban1.1.0 compilation?

Observation:
It seem that wx-config could not be found in debian packages?!

Thanks.

Regards, Noli

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Tue, 26 Jul 2005 09:42:46 +0200

> Manage to get thuban working.

great :-)

> python setup.py build_ext --use-wx-python-swig-hack  install_local

so, it seems the Debian package maintainer hasn't fixed that problem
yet.

> wxpython2.6.1.0 from from wxpython.org src.rpm by rpmbuild and alien

not that the version number must always be identical, ie. when you
are using wxPython 2.6.1.0, then you must have wxWidgets 2.6.1.0.

> Python-gdal, since debian python-gdal1.2.6.1 uses <python2.4

what is the actual problem?

> python-gdal > 1.2.5 as recommended for Thuban1.1.0 compilation?

If you are on a Debian, then you should better use the Debian
package for gdal.
gdal version 1.2.5 is a new requirement to have the raster support
work properly.

> It seem that wx-config could not be found in debian packages?!

yes, thats strange. Entering
$ dpkg -S wx-config
I do not find it, but it is installed:
$ type wx-config
wx-config is /usr/bin/wx-config
(I am on a Debian 3.1 Sarge)

Anyone an idea about this?

Best

	Jan
-- 
Jan-Oliver Wagner               http://intevation.de/~jan/
Intevation GmbH                      http://intevation.de/
Kolab Konsortium               http://kolab-konsortium.de/
FreeGIS                                http://freegis.org/