Subject: [Thuban-list] (no subject)

From: "Serviopa" <[email-masked]>
Date: Mon, 25 Jul 2005 23:13:15 -0300

>hm, could comment out lines 37 and 38 in Thuban/UI/__init__.py
>and try again?

>Might be a wx 2.6.1 issue. Anyone else here using
>wx 2.6.1 possibly even on Mandriva not havin this problem?
>(Or reproducing the problem?)

Yes, commentig those lines made Thuban start. But it still complains about
no pt_pt encoding when some other routine calls similar translation
functions. Maybe because there is no such pt_pt encoding, but there is a
pt_PT encoding or locale.

For instance, whe I try to set or see the projection of a tiff layer, I get
this:

An unhandled exception occurred:
unknown encoding: pt_pt
(please report to http://thuban.intevation.org/bugtracker.html)

Traceback (most recent call last):
File "/usr/local/lib/thuban/Thuban/UI/mainwindow.py", line 300, in
invoke_command
command.Execute(self.Context())
File "/usr/local//lib/thuban/Thuban/UI/command.py", line 121, in Execute
apply(self.function, (context,) + self.args + args, kw)
File "/usr/local/lib/thuban/Thuban/UI/mainwindow.py", line 1074, in
call_method
apply(getattr(context.mainwindow, methodname), args)
File "/usr/local/lib/thuban/Thuban/UI/mainwindow.py", line 782, in
LayerProjection
_("Layer Projection: %s") % layer.Title(), layer)
File "/usr/local//lib/thuban/Thuban/UI/projdialog.py", line 73, in __init__
self.build_dialog()
File "/usr/local//lib/thuban/Thuban/UI/projdialog.py", line 99, in
build_dialog
proj_files = [self.load_user_proj(),
File "/usr/local//lib/thuban/Thuban/UI/projdialog.py", line 616, in
load_system_proj
projfile, warnings = get_system_proj_file(name)
File "/usr/local/lib/thuban/Thuban/Model/resource.py", line 133, in
get_system_proj_file
return read_proj_file(fullname)
File "/usr/local/lib/thuban/Thuban/Model/resource.py", line 87, in
read_proj_file
handler.read(filename)
File "/usr/local/lib/thuban/Thuban/Model/resource.py", line 171, in read
XMLReader.read(self, file_or_filename)
File "/usr/local//lib/thuban/Thuban/Model/xmlreader.py", line 75, in read
parser.parse(self.__file)
File "/usr/lib/python2.4/site-packages/_xmlplus/sax/expatreader.py", line
109, in parse
xmlreader.IncrementalParser.parse(self, source)
File "/usr/lib/python2.4/site-packages/_xmlplus/sax/xmlreader.py", line 123,
in parse
self.feed(buffer)
File "/usr/lib/python2.4/site-packages/_xmlplus/sax/expatreader.py", line
216, in feed
self._parser.Parse(data, isFinal)
File "/usr/lib/python2.4/site-packages/_xmlplus/sax/expatreader.py", line
353, in start_element_ns
AttributesNSImpl(newattrs, qnames))
File "/usr/local//lib/thuban/Thuban/Model/xmlreader.py", line 114, in
startElementNS
getattr(self, method_name[0])(name, qname, attrs)
File "/usr/local/lib/thuban/Thuban/Model/resource.py", line 177, in
start_projection
name = self.encode(attrs.get((None, 'name')))
File "/usr/local//lib/thuban/Thuban/Model/xmlreader.py", line 134, in encode
return internal_from_unicode(str)
File "/usr/local//lib/thuban/Thuban/__init__.py", line 101, in
internal_from_unicode
return unistr.encode(_internal_encoding, "replace")
LookupError: unknown encoding: pt_pt

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Tue, 26 Jul 2005 09:32:07 +0200

> An unhandled exception occurred:

I think, we must first concentrate on where this "pt_pt" comes from.
Does it appear on the list when you type
$ locale
?

Best

	Jan
-- 
Jan-Oliver Wagner               http://intevation.de/~jan/
Intevation GmbH                      http://intevation.de/
Kolab Konsortium               http://kolab-konsortium.de/
FreeGIS                                http://freegis.org/