Subject: [Thuban-list] Session tree/Legend: toggles?

From: Jan-Oliver Wagner <[email-masked]>
Date: Fri, 4 Apr 2003 17:11:18 +0200

Hi,

I wonder whether it would be nice to make the
menu items "Show Session Tree" and "Show Legend"
toggleable menu items "Session Tree" and "Legend"
(and without a separator between them).

I tend to say yes - what is your opinion?

	Jan

-- 
Jan-Oliver Wagner               http://intevation.de/~jan/

Intevation GmbH	              	     http://intevation.de/
FreeGIS	                               http://freegis.org/

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Mon, 7 Apr 2003 12:56:52 +0200

> I tend to say yes - what is your opinion?

since no complaints arrived, we'll go for toggleable items :-)

However, what also came to my mind here is that 'Legend'
actually refers to a map, not to the overall session.
Hence, the menu item should actually be placed into the map menu.

	Jan

---

From: Bernhard Herzog <[email-masked]>
Date: 07 Apr 2003 13:06:29 +0200

> since no complaints arrived, we'll go for toggleable items :-)

And it's already in CVS :)

The commands in question have been renamed to toggle_session_tree and
toggle_legend.

   Bernhard

-- 
Intevation GmbH                                 http://intevation.de/
Sketch                                 http://sketch.sourceforge.net/
MapIt!                                           http://www.mapit.de/

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Mon, 7 Apr 2003 14:19:32 +0200

> And it's already in CVS :)

cool. Thats what i had in mind.

Now the item 'Legend' just needs to moved to the 'Map' menu.

---

From: Bernhard Herzog <[email-masked]>
Date: 07 Apr 2003 15:14:52 +0200

> Now the item 'Legend' just needs to moved to the 'Map' menu.

I wonder: Wouldn't it make even more sense to introduce a View menu? It
would contain e.g. "Legend" as well as "Full Extent", "Zoom In", "Zoom
Out" and "Pan".

   Bernhard

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Mon, 7 Apr 2003 15:26:42 +0200

> would contain e.g. "Legend" as well as "Full Extent", "Zoom In", "Zoom

it might make sense at a later stage, but so far I think that
the Map menu is not too overcrowded. Also a clear definition
of the difference between a View and a Map might be difficult.

---

From: Bernhard Herzog <[email-masked]>
Date: 07 Apr 2003 15:38:10 +0200

> > > Now the item 'Legend' just needs to moved to the 'Map' menu.

Checked in now.

> of the difference between a View and a Map might be difficult.

The main difference would be that the commands in the map menu change
the map in some way while the commands in the view menu only affect how
the map is displayed.

   bernhard