Subject: [Thuban-list] Strange exception for user.proj

From: Jan-Oliver Wagner <[email-masked]>
Date: Mon, 29 Sep 2003 14:27:26 +0200

Hi,

I've inserted a special projection into ~/.thuban/user.proj
which makes Thuban through

| Exception exceptions.AttributeError: <exceptions.AttributeError instance at 0x10ac7018> in  ignored

The projection origintates from the epsg file of the proj package.
I wrote a small converter to produce a Thuban .proj file from the epsg
file. However, at least for this projection (user.proj is attached)
I get an exception when opening the Map Projection dialog.

	Jan
-- 
Jan-Oliver Wagner               http://intevation.de/~jan/

Intevation GmbH	              	     http://intevation.de/
FreeGIS	                               http://freegis.org/

---

From: Bernhard Herzog <[email-masked]>
Date: Mon, 29 Sep 2003 14:34:20 +0200

> file. However, at least for this projection (user.proj is attached)

That user.proj contains an empty projectionlist and AFAICT Thuban
(current CVS) doesn't have any problems with it.

   Bernhard

-- 
Intevation GmbH                                 http://intevation.de/
Sketch                                 http://sketch.sourceforge.net/
Thuban                                  http://thuban.intevation.org/

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Mon, 29 Sep 2003 15:55:42 +0200

> (current CVS) doesn't have any problems with it.

sorry, wrong user.proj.
Now attached the one that produces the exception.

---

From: Bernhard Herzog <[email-masked]>
Date: Mon, 29 Sep 2003 16:47:48 +0200

> Now attached the one that produces the exception.
[...]
> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE projfile SYSTEM "projfile.dtd">
> <projectionlist>
>     <projection name="EPSG 256: CH1903+ / LV95">
>         <parameter value="proj=omerc"/>
>         <parameter value="lat_0=46.952405556"/>
>         <parameter value="lonc=7.439583333"/>
>         <parameter value="alpha=90.000000000"/>
>         <parameter value="k=1.000000000"/>
>         <parameter value="x_0=2600000.000"/>
>         <parameter value="y_0=1200000.000"/>
>         <parameter value="ellps=bessel"/>
>         <parameter value="units=m"/>
>     </projection>

Well, proj doesn't like the parameters:
proj +proj=omerc +lat_0=46.952405556 +lonc=7.439583333 +alpha=90.000000000 +k=1.000000000 +x_0=2600000.000 +y_0=1200000.000 +ellps=bessel units=m
Rel. 4.4.5, 9 January 2002
<proj>: 
projection initialization failure
cause: lat_0 = 0 or 90 or alpha = 90
program abnormally terminated

That Thuban doesn't give you a better error message is obviously a bug
in Thuban. I filed a new bug report for it:
https://intevation.de/rt/webrt?serial_num=2138

---

From: Jonathan Coles <[email-masked]>
Date: Mon, 29 Sep 2003 10:50:23 -0400

> I get an exception when opening the Map Projection dialog.

thuban doesn't have a dialog for proj=omerc. there is only one for
tmerc. when i changed from omerc to tmerc (ignoring what that really
means) i didn't get the exception.

--jonathan

-- 
=========================================================================
 Jonathan Coles                                   http://www.jpcoles.com 
 [email-masked]  GnuPG Key: http://www.jpcoles.com/gpg_pub_key.asc 
=========================================================================

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Thu, 2 Oct 2003 15:24:10 +0200

> means) i didn't get the exception.

I have added a corresponding hint into the bug tracker.
Also some further analysis and a proposal how to solve it:
https://intevation.de/rt/webrt?serial_num=2138&display=History