Subject: [Thuban-list] RE: Thuban1.1.0 rpm, deb

From: <[email-masked]>
Date: Wed, 27 Jul 2005 10:37:01 +1000

> In (K)ubuntu using:
> Python2.4.1
> wxwidget2.6 from http://http.us.debian experimental, but not
wxpython2.6
> since no dev package
> wxpython2.6.1.0 from from wxpython.org src.rpm by rpmbuild and alien

* not that the version number must always be identical, ie. when you
* are using wxPython 2.6.1.0, then you must have wxWidgets 2.6.1.0.

My wxWidgets is 2.6.1.1. Right now is Thuban is segment faulting when
opening shp file, probably because I built wxPython 2.6.1.0 before
installing wxWidgets 2.6.1.1.

My gtk is 2.6.2.

> No
> Python-gdal, since debian python-gdal1.2.6.1 uses <python2.4

* what is the actual problem?

Python-gdal1.2.6.1 uses python 2.3 (<python2.4, should I say less than
python2.4), (K)ubuntu uses python2.4 as default. 

> Where could I found python-gdal 1.2.6.1 src.rpm or where do you keep
> python-gdal > 1.2.5 as recommended for Thuban1.1.0 compilation?

*If you are on a Debian, then you should better use the Debian
*package for gdal.
*gdal version 1.2.5 is a new requirement to have the raster support
*work properly.

Again, I could not use since the reason above, python2.4 in Ubuntu.

> Observation:
> It seem that wx-config could not be found in debian packages?!

*yes, thats strange. Entering
*$ dpkg -S wx-config
*I do not find it, but it is installed:
*$ type wx-config
*wx-config is /usr/bin/wx-config
*(I am on a Debian 3.1 Sarge)

*Anyone an idea about this?

This is really strange. I use:
$ locate wx-config

Nothing can be found except the documentation and wx-configure.in in the
Kdeveloper

Yes, it is installed in /usr/bin/wx-config

Anybody, in the list using Kubuntu or Ubuntu?

Thanks, Noli

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Wed, 27 Jul 2005 22:26:48 +0200

> installing wxWidgets 2.6.1.1.

we experienced various problems when the versions do not match.

> My gtk is 2.6.2.

I don't think, the gtk version matters a lot.

> Again, I could not use since the reason above, python2.4 in Ubuntu.

what I meant was to rebuild the debian source package on your system.
Then you should have a working version.
This way is much easier and better than starting to involve a
rpm via alien on a debian system.

> Nothing can be found except the documentation and wx-configure.in in the

locate database might be out of date.

> Anybody, in the list using Kubuntu or Ubuntu?

anyone?

Best

	Jan
-- 
Jan-Oliver Wagner               http://intevation.de/~jan/
Intevation GmbH                      http://intevation.de/
Kolab Konsortium               http://kolab-konsortium.de/
FreeGIS                                http://freegis.org/

---

From: Bernhard Reiter <[email-masked]>
Date: Sun, 14 Aug 2005 10:56:37 +0200

Hi Thubanistas,

> On Wed, Jul 27, 2005 at 10:37:01AM +1000, [email-masked] wrote:

though I am not using (K)Ubuntu, I had a system once
and believe it is close enough to Debian.

> Then you should have a working version.

I agree, when you want a Debian Package on your System that does not
fit the binary perfectly rebuilding from source is easy.
Here are the typical steps:

For a hypothecial packages X (including packages name and version numers)
download 
	X.orig.tar.gz, 
	X.diff (if it exists, there are native packages, which have none.)
	X.dsc

dpkg-source -x X.dsc
#Manual check the build depends in .dsc and make sure they are installed.
cd X
nice fakeroot debian/rules binary

# now you should have a nice binary, that you can install with 
	dpkg  --install

Okay, that was a general remark, 

> > *(I am on a Debian 3.1 Sarge)

This binary is a link over Debian's alternative system.
Here is how you can find out which package it comes from:

type wx-config
wx-config is /usr/bin/wx-config
$ ls -l /usr/bin/wx-config
lrwxrwxrwx    1 root     root           27 21. Mär 2002  /usr/bin/wx-config -> /etc/alternatives/wx-config
$ ls -l /etc/alternatives/wx-config
lrwxrwxrwx    1 root     root           25  3. Nov 2004  /etc/alternatives/wx-config -> /usr/bin/wxgtk-2.2-config
$ dpkg --search /usr/bin/wxgtk-2.2-config
libwxgtk2.2-dev: /usr/bin/wxgtk-2.2-config

> locate database might be out of date.

Probably.
As root you would run "updatedb" to update the database.

On the system above locate worked and showed me the symlinks.
On Jan's sarge system it did not.

Here is the output for a Sarge System:

ls -l /usr/bin/wx-config
lrwxrwxrwx  1 root root 27 2005-06-28 09:12 /usr/bin/wx-config -> /etc/alternatives/wx-config
$ ls -l /etc/alternatives/wx-config
lrwxrwxrwx  1 root root 25 2005-06-28 09:12 /etc/alternatives/wx-config -> /usr/bin/wxgtk-2.4-config
$ dpkg --search /usr/bin/wxgtk-2.4-config
libwxgtk2.4-dev: /usr/bin/wxgtk-2.4-config

Best,
	Bernhard