Subject: [Thuban-list] No module sqlite in Mandrake 10

From: Servio Tulio Pires Amarante <[email-masked]>
Date: Wed, 10 Mar 2004 20:25:05 +0000

I have compiled and successful installed Thuban, but it does start saying 
that:
$ thuban
Traceback (most recent call last):
  File "/usr/local/bin/thuban", line 20, in ?
    import Thuban.UI.main
  File "/usr/local//lib/thuban/Thuban/UI/main.py", line 18, in ?
    from application import ThubanApplication
  File "/usr/local//lib/thuban/Thuban/UI/application.py", line 26, in ?
    from Thuban.Model.session import create_empty_session
  File "/usr/local//lib/thuban/Thuban/Model/session.py", line 25, in ?
    from data import ShapefileStore
  File "/usr/local//lib/thuban/Thuban/Model/data.py", line 23, in ?
    import transientdb
  File "/usr/local/lib/thuban/Thuban/Model/transientdb.py", line 21, in ?
    from sqlite import connect
ImportError: No module named sqlite

I have sqlite installed and running fine here. I have tried it with both 
rebuilt rpm or tarball packages. Any cue on what is going on?

Thanks

S.

---

From: Martin Schulze <[email-masked]>
Date: Thu, 11 Mar 2004 07:37:23 +0100

> rebuilt rpm or tarball packages. Any cue on what is going on?

Do you have it's Python binding installed as well?  Without it,
Python can't access it.  You'll find the source here:

http://pysqlite.sourceforge.net/downloads/

Python is looking for the Python module sqlite, not for the separate
sqlite package.

Regards,

	Joey

-- 
There are lies, statistics and benchmarks.

---

From: Servio Tulio Pires Amarante <[email-masked]>
Date: Thu, 11 Mar 2004 20:01:31 +0000

Em Qui 11 Mar 2004 06:37, Martin Schulze escreveu:

> _______________________________________________
> Thuban-list mailing list
> [email-masked]
> https://intevation.de/mailman/listinfo/thuban-list
> 

Yes, I had. Installed from a rpm package, pysqlite-0.4.3-1.i386.rpm, not a 
rpm-mdk package. I removed it and installed the latest tarballs, 0.5.0. It 
solved my problem.

Thanks

S.