Subject: [Thuban-list] added classification support

From: Jonathan Coles <[email-masked]>
Date: 27 Jan 2003 13:21:25 +0100

The following initial updates are now in the cvs repository:

layer.py -- classification initialization calls

classification.py -- created class to encapsulate a layer 
                     classification. Supports specific data 
                     points and ranges.

load.py -- add support for loading classification information

save.py -- add support for saving classification information

classifier.py -- initial class for a dialog

mainwindow.py -- support for opening the classifier dialog

renderer.py -- support for drawing a layer with the classification
               information

iceland_sample_class.thuban -- iceland_sample with classification data

test_classification -- tests for the Classification class

--jonathan

---

From: Thomas Koester <[email-masked]>
Date: Mon, 27 Jan 2003 14:53:07 +0100

> The following initial updates are now in the cvs repository:

I installed a current Thuban checkout with
python setup.py install --prefix /home/tkoester/Project/greater/install

This is the error I get when trying to run it:

Traceback (most recent call last):
  File "./thuban", line 21, in ?
    import Thuban.UI.main
  File "/home/tkoester/Project/greater/install/lib/thuban/Thuban/UI/main.py", line 18, in ?
    from application import ThubanApplication
  File "/home/tkoester/Project/greater/install/lib/thuban/Thuban/UI/application.py", line 24, in ?
    from Thuban.Model.load import load_session
  File "/home/tkoester/Project/greater/install/lib/thuban/Thuban/Model/load.py", line 23, in ?
    from Thuban.Model.layer import Layer
  File "/home/tkoester/Project/greater/install/lib/thuban/Thuban/Model/layer.py", line 22, in ?
    from classification import Classification
ImportError: No module named classification

Thomas

-- 
Email: [email-masked]
http://intevation.de/~tkoester/

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Mon, 27 Jan 2003 15:01:26 +0100

On Mon, Jan 27, 2003 at 02:53:07PM +0100, Thomas Koester wrote:
>...

this file should now be in CVS.

-- 
Jan-Oliver Wagner               http://intevation.de/~jan/

Intevation GmbH	              	     http://intevation.de/
FreeGIS	                               http://freegis.org/

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Mon, 27 Jan 2003 15:23:36 +0100

> layer.py -- classification initialization calls

the sample looks nice. Calling the menu item Classify does not
work yet.

---

From: Jonathan Coles <[email-masked]>
Date: 28 Jan 2003 13:55:23 +0100

Classify menu item should not crash Thuban now.

--jonathan

On Mon, 2003-01-27 at 15:23, Jan-Oliver Wagner wrote:
> _______________________________________________
> Thuban-list mailing list
> [email-masked]
> https://intevation.de/mailman/listinfo/thuban-list