Subject: [Thuban-list] cvs putback

From: Jonathan Coles <[email-masked]>
Date: 10 Feb 2003 16:28:56 +0100

Just putback the latest classification changes. Updates to the dialog
box, load and save routines, and internal data representation. See the
ChangeLog for more details.

--jonathan

-- 
Jonathan Coles
Intevation GmbH
http://www.intevation.net

---

From: Jan-Oliver Wagner <[email-masked]>
Date: Mon, 10 Feb 2003 16:45:39 +0100

> ChangeLog for more details.

I get an exception when trying to load the iceland sample for
classification:

| Warning: <C wxPyApp instance at _85e21a8_wxPyApp_p>.SESSION_CHANGED:
| <method SessionTreeCtrl.session_changed of SessionTreeCtrl instance at
| 0x860d514>()
| Traceback (most recent call last):
|   File "./Thuban/Lib/connector.py", line 89, in Issue
|     apply(func, args + fargs)
|   File "/powerhome/jan/project/thuban/Thuban/UI/tree.py", line 162, in
| session_changed
|     self.update_tree()
|   File "/powerhome/jan/project/thuban/Thuban/UI/tree.py", line 93, in
| update_tree
|     self.add_items(root, info[1])
|   File "/powerhome/jan/project/thuban/Thuban/UI/tree.py", line 119, in
| add_items    self.add_items(treeitem, info[1])
|   File "/powerhome/jan/project/thuban/Thuban/UI/tree.py", line 119, in
| add_items    self.add_items(treeitem, info[1])
|   File "/powerhome/jan/project/thuban/Thuban/UI/tree.py", line 116, in
| add_items    info = item.TreeInfo()
|   File "/powerhome/jan/project/thuban/Thuban/Model/classification.py",
| line 185, in TreeInfo
|     items.append((_("'DEFAULT'"), build_item(self.DefaultData)))
|   File "/powerhome/jan/project/thuban/Thuban/Model/classification.py",
| line 178, in build_item
|     i.append((_("Stroke: %s") % color_string(v), v))
| NameError: global name 'color_string' is not defined

-- 
Jan-Oliver Wagner               http://intevation.de/~jan/

Intevation GmbH	              	     http://intevation.de/
FreeGIS	                               http://freegis.org/