Subject: 1.3.1 things I have noticed

From: Bernhard Reiter <[email-masked]>
Date: Fri, 4 Nov 2005 21:50:19 +0100

Hi Jakson,

some things I have noticed:

        a)
        --xcols does not seem to go well with --silent.
        I have noticed when trying run_statist.sh in your test_xcols.sh
        script.

        b) I have noticed a bug while noticing a), even if the
        test failed, it did not properly report it. I have fixed
        this in CVS.

        c) Jakson: You should add yourself on the welcome message
                as copyright holder for 2005.

Bernhard

---

From: "Jakson A. Aquino" <[email-masked]>
Date: Fri, 4 Nov 2005 21:25:57 -0200

Hi Bernhard,

>         I have noticed when trying run_statist.sh in your test_xcols.sh

--xcols is hard coded to be used like:
statist  --xcols  config_file  fixed_width_data_file  dest_file

and not like:
statist [options] --xcols  config_file  fixed_width_data_file  dest_file

Although this sequence of commands is documented in the
--help message, in the man page, and in the user manual,
something more flexible would be better. Currently, the
parameters passed to the program must be exactly the 4 above
and in the same sequence. I can add this problem to
KNOWN_BUGS and try to make it more flexible for the next
release.

>                 as copyright holder for 2005.

Do you mean something like the following?:

------------------
jakson@:src$ ./statist --version

STATIST --- Version 1.3.1-cvs --- 
 (C) Dirk Melcher 1997-1999
 (C) Jakson Aquino 2005
 Published by Bernhard Reiter 1998-2005.
 STATIST comes with ABSOLUTELY NO WARRANTY; it is Free Software under GNU GPL.
 Read the file COPYING for details.
-------------------

Best,

Jakson

---

From: Bernhard Reiter <[email-masked]>
Date: Mon, 7 Nov 2005 12:21:34 +0100

Hi Jakson,

> KNOWN_BUGS and try to make it more flexible for the next

Yes, this clearly is a bug and should be different.

> Do you mean something like the following?:

Yes, you can make this "(C)" for me, too, as I ended up writing some code
over the years.

Best,
	Bernhard

---

From: "Jakson A. Aquino" <[email-masked]>
Date: Mon, 7 Nov 2005 15:45:40 -0200

Hi Bernhard,

> Yes, this clearly is a bug and should be different.

I added it to the KNOWN_BUGS before the release.

Is it enough if statist accepts the following:

  statist [options] --xcols  config_file  fixed_w_file  dest_file [options]

Or even more flexibility is desirable?

> Yes, you can make this "(C)" for me, too, as I ended up writing some code
 
Then, we'll have:

STATIST --- Version 1.3.1-cvs --- 
 (C) Dirk Melcher 1997-1999
 (C) Bernhard Reiter 1998-2005.
 (C) Jakson Aquino 2005
 STATIST comes with ABSOLUTELY NO WARRANTY; it is Free Software under GNU GPL.

But what about the "Published by" expression? We still have
to include it?

Best,

Jakson

---

From: Bernhard Reiter <[email-masked]>
Date: Sat, 12 Nov 2005 17:37:15 +0100

> Or even more flexibility is desirable?

should be fine enough, though, if you want --xcols to be an option 
with three parameters, this picture would look like:

	statist [options]
:)

> But what about the "Published by" expression? We still have

No, I think it is fine when the history is preserved in the documentation.

	Bernhard