Subject: translations

From: Jakson Aquino <[email-masked]>
Date: Sun, 31 Jul 2005 22:35:45 -0300

Hello All!

I'll not do any change in the Statist strings
during the next weeks. So, the po files are
ready for translation. I have just updated the
po directory. Now, the strings are sorted by
source file. There are less than 10 fuzzy
messages and less than 30 new messages in the po
files. Poedit, and Kbabel are helpful
applications.

Do we have volunteer translators?

The past translations (Spanish and Italian) were
made respectively by Carleos Artime and Nicola
Intini. Could you translate the new strings?

The new messages have to be translated into
German in two places: the po file and the source
code. Currently, they are in English in the
source code. Who will be our German volunteer?
Bernhard?

Regarding the version number, since 1.1.0 is too
low a number, I think we can jump to 1.3.0.
I prefer to use an even number only when more
users have used the current version of Statist
for some time.

Today I compiled Statist under DOS/Windows with
gettext support using MinGW (included in
Dev-C++) and CygWin. With CygWin Statist works
like in Linux, with no limitations. With MinGW
the gnuplot has to be opened separately, but it
works fine with Statist. After plotting a new
graphic we have just to open stat_gpl.com again.
One problem with both compilations was that the
accents aren't being correctly printed in the
screen. The accents are correctly printed only
in the graphics generated by Statist compiled in
with Dev-C++/MinGW. During the next week, I'll
make the necessary changes in the src/Makefile
and the README file to make it easier for people
to compile Statist under DOS/Windows.

Best regards,

Jakson

		
_______________________________________________________ 
Yahoo! Acesso Grátis - Internet rápida e grátis. 
Instale o discador agora! http://br.acesso.yahoo.com/

---

From: Bernhard Reiter <[email-masked]>
Date: Mon, 1 Aug 2005 14:45:38 +0200

Hi Jakson,

Am 31. Jul 2005 um 22:35:45 schrieb Jakson Aquino:
> ready for translation. 

nice!

> source code. Who will be our German volunteer?

Currently I cannot promise anything.
So I would prefer if somebody else would step in.
Doing the translations is fairly easy.

> low a number, I think we can jump to 1.3.0.

Fine with me.

> During the next week, I'll

Good.
One idea of not making gettext a necessity were
very old systems (286) or embedded systems with smaller c-libraries,
like dietlibc that might not have gettext.
	
	Bernhard

---

From: Jakson Aquino <[email-masked]>
Date: Wed, 3 Aug 2005 22:14:07 -0300

Hello!

Gettext support is working on DOS with ibintl3.dll which
is one of the GnuWin32 packages. The compilation was
done with MinGW gcc that comes with Dev-C++.

On Windows I couldn't set the LOCALEDIR in the Makefile.
The LOCALEDIR is always defined as integer, and not as
string as happens on Linux.  The solution that I found was
to use a fix place for catalogs: %WINDIR%/locale. However,
I'm not sure that the environment variable %WINDIR% is
defined in all versions of Windows.

I didn't find on the Internet an "official" solution to
the problem of accents on DOS.  However, the accents are
correctly displayed (on Windows 98) if we use iconv to
convert the charset encoding of the po files to cp850 but
keep the information "CHARSET=iso8859-1" in the po file
header. This works for the messages displayed in the DOS
window. The 12 messages sent to gnuplot have to be
converted back to iso-8859-1 in the po files.

I couldn't solve the accents problem in CygWin. A letter
ä, for example, is being displayed as "a. I have two sed
scripts to strip the accents from letters. One for German
(ü, for example, becomes ue) and other for the other
languages (ü becomes u). I can put the scripts on the po
directory. Or would it be better to add them to another
place, like a web page with contributions for Statist?

> like dietlibc that might not have gettext.

I used a pre-compiled binary of libintl, but certainly it
would be possible to compile the library in small C
systems. Indeed, libintl is small. However, libiconv isn't
and perhaps using libintl as it is currently implemented
would turn small systems into big ones. But I believe that
it would not be difficult to create a special version of
libintl without using libiconv, and using only the 26
English letters, like the Statist language macros (but I
don't intend to try creating this libintl). With
Western European languages it would work reasonably well
and the systems would stay small. It's very easy to strip.

Best,

Jakson

---

From: Bernhard Reiter <[email-masked]>
Date: Sun, 7 Aug 2005 11:57:42 +0200

Hi Jakson,

> place, like a web page with contributions for Statist?

I would put them in CVS.
Maybe in a different place, but not in "contrib" as they are 
done by yourself which makes them official. ;)

> and the systems would stay small. It's very easy to strip.

This is just a general idea of mine, I have never though much more
about the requirements of smaller systems except that I was very
happy years ago, that statist ran on 286 systems.
We did not have the gettext then, so I do not know if this is
actually a concern for real users.
So do not go to length to make this possible, unless you aim at a
special target group.

Best,	
	Bernhard

---

From: Bernhard Reiter <[email-masked]>
Date: Thu, 11 Aug 2005 16:43:55 +0200

> Doing the translations is fairly easy.

I had some time in a train and did a first translation in the .po only
and checked it into CVS. I hope it is helpful to some regard.