Subject: compilation of statist under cygwin

From: [email-masked]
Date: Mon, 29 Mar 2004 10:55:48 +0200 (MEST)

Hello all,

I am having problems to compile statist (v1.0.1) under cygwin, please see
the error messages below. The same error messages occur also with the -DMSDOS
flag. Can anybody help?

Best regards,
Stefan

[fronzek@KK450 ...statist/src]$ gcc -v
Reading specs from /usr/lib/gcc-lib/i686-pc-cygwin/2.95.3-5/specs
gcc version 2.95.3-5 (cygwin special)

[fronzek@KK450 ...statist/src]$ make
gcc -c -Wall  -DNO_GETTEXT -DLANG=LANG_EN  statist.c
gcc -c -Wall  -DNO_GETTEXT -DLANG=LANG_EN  menue.c
gcc -c -Wall  -DNO_GETTEXT -DLANG=LANG_EN  procs.c
gcc -c -Wall  -DNO_GETTEXT -DLANG=LANG_EN  funcs.c
gcc -c -Wall  -DNO_GETTEXT -DLANG=LANG_EN  data.c
gcc -c -Wall  -DNO_GETTEXT -DLANG=LANG_EN  plot.c
gcc -c -Wall  -DNO_GETTEXT -DLANG=LANG_EN    -c -o memory_handling.o
memory_handling.c
gcc -o statist statist.o menue.o procs.o funcs.o data.o plot.o
memory_handling.o
 -lm
statist.o(.text+0x59b):statist.c: undefined reference to `errno'
statist.o(.text+0x753):statist.c: undefined reference to `errno'
menue.o(.text+0x410c):menue.c: undefined reference to `errno'
menue.o(.text+0x4238):menue.c: undefined reference to `errno'
menue.o(.text+0x495a):menue.c: undefined reference to `errno'
menue.o(.text+0x4aef):menue.c: more undefined references to `errno' follow
collect2: ld returned 1 exit status
make: *** [statist] Error 1

-- 
+++ NEU bei GMX und erstmalig in Deutschland: TÜV-geprüfter Virenschutz +++
100% Virenerkennung nach Wildlist. Infos: http://www.gmx.net/virenschutz

---

From: Bernhard Reiter <[email-masked]>
Date: Mon, 29 Mar 2004 11:41:24 +0200

Hello Stefan,

actually errno should be defined by the compiler.
Maybe adding the include will help,
try adding the following line to the top of statist.h
	#include <errno.h>

Let me know the results.
	Bernhard