Subject: probability, not frequency

From: Alexandre Cunha <[email-masked]>
Date: Tue, 26 Jun 2001 07:21:18 -0400

hi

thanks for statist. simple, sharp and it uses gnuplot, which is great.

questions: is there a way to get the probability instead of the
frequency values in the distribution histogram plots ?
also, how can i force statist to plot within a y-range i specify ? i
could not do it even specifying the y-range before any plotting is done.
a replot would not accept changes in range values.

please, reply to my account directly since I am not in the mailing list
(yet!).
thanks,
- alex.

---

From: Bernhard Reiter <[email-masked]>
Date: Tue, 26 Jun 2001 21:42:31 +0200

> frequency values in the distribution histogram plots ?

I don't think so, but you can add it easily.
The function plot_histo could be copied and plotting with steps.
You need to call it from a function like histogram() just adding the
number from the previous class.

> a replot would not accept changes in range values.

Just looked it up in the source code:
statist uses plot commands specifying the ranges, like
	"plot [%g:%g][%i:%i] '%s' with boxes linetype linetype"

You have two possibilities:
	Change this in plot.c and recompile.

	Check the last plot command with "show all" and
	copy it replacing the ranges with something better.

Hope this gives some hints,
	Bernhard

-- 
Professional Service around Free Software                (intevation.net)  
The FreeGIS Project                                         (freegis.org)
Association for a Free Informational Infrastructure            (ffii.org)
FSF Europe                                            	  (fsfeurope.org)

---

From: Bernhard Reiter <[email-masked]>
Date: Wed, 27 Jun 2001 16:33:25 +0200

You are welcome.
Glad you found a solution.
	Bernhard

On Wed, Jun 27, 2001 at 08:53:31AM -0400, Alexandre Cunha wrote:
> Thanks. Before start doing the coding I realized I can get the histogram 
> values via -noplot and I am storing those values in a file to be ploted 
> directly by gnuplot. For now, it is just fine.
> 
> On Tuesday 26 June 2001 15:42, you wrote:
>

---

From: Bernhard Reiter <[email-masked]>
Date: Sat, 30 Jun 2001 16:36:03 +0200

Andreas send me a patch today which can be found in the contrib
directory (check the readme before applying).
It will will make statist output output propabilities instead of frequencies.