Subject: binaries and documentation

From: Jakson Aquino <[email-masked]>
Date: Mon, 15 Aug 2005 21:55:01 -0300

Hi Bernhard,

I found a script in my computer that ask me some 
questions and create a deb package. I can, then use 
alien to create a rpm package, and make both packages 
available for download after the release. My question 
is, what about the documentation? We don't have info 
pages, and the pdf docs might be put 
into /usr/share/doc/statist-1.3.0/ but I fear that 
some user migrating from Windows would have difficult 
to guess where the documentation is.

One idea is to add the item "Help" to the main menu. 
Choosing the item would print a message telling where 
the documentation can be found.

Best,

Jakson

		
_______________________________________________________ 
Yahoo! Acesso Grátis - Internet rápida e grátis. 
Instale o discador agora! http://br.acesso.yahoo.com/

---

From: Bernhard Reiter <[email-masked]>
Date: Tue, 16 Aug 2005 16:49:22 +0200

Hi Jakson,

Am 15. Aug 2005 um 21:55:01 schrieb Jakson Aquino:
> questions and create a deb package. 

:) 
which one did you use?

> I can, then use 
> available for download after the release. 

It is probably better then nothing, but hand crafted packages
usually are better. They should be fairly easy to do.
A Debian version was done some time ago, 
check the archive of the list.
It should provide a start.

> My question 
> into /usr/share/doc/statist-1.3.0/ 

Fine, but why not "/usr/share/doc/statist/"?

> but I fear that 

I think a short manpage refering to the documentation would even be better.
A point just pointing to the installed documentation seems to be
a bit missleading.

There are tools to create a simple manpage.
Starting to use texinfo might be a hassle but also a future option,
if someone is willing to do the work.

	Bernhard

---

From: Jakson Aquino <[email-masked]>
Date: Tue, 16 Aug 2005 17:10:03 -0300

i Bernhard,

Em Tuesday 16 August 2005 11:49, Bernhard Reiter 
> > questions and create a deb package.

It was a script written by Carlos Morimoto, the author 
of Kurumin, a Brazilian Linux distro based on Kanoppix 
(which is based on Debian). I'm not using the script. 
I just look at it to know what commands were necessary 
to create another script specific for statist.

> usually are better. They should be fairly easy to do.

We can have total control over the debian package with 
the script.

For the second step, the convertion into rpm, I'm 
asking "alien" to just create the directory and spec 
file, which have to be manually edited before building 
the package.

The packages are working. I installed and uninstalled 
them in both Fedora Core 2 and Kurumin. I'm sending 
the script as an attachment, so you can make 
suggestions to improve it. The "man page" is inside 
the script. Although it's not formatted, it's 
correctly displayed.

> It should provide a start.

I tried the link, but I got an error with both firefox 
and wget.

> if someone is willing to do the work.

Is there something like tex2texinfo ?

Best,

Jakson

---

From: Bernhard Reiter <[email-masked]>
Date: Wed, 17 Aug 2005 09:48:42 +0200

Hi Jakson,

> > It is probably better then nothing, but hand crafted 
> > packages usually are better. They should be fairly easy to do.
> 

Still, we could run it once and then have a debian directory
we would check into CVS.

> I'm sending 
> suggestions to improve it. 

I think it probably lacks the Build dependencies
and the dependencies. Also why should this be i386 only?

> The "man page" is inside 

Probably because he just installs a formatted one. ;)

> I tried the link, but I got an error with both firefox 

Which one did you try?
Maybe we can try contacting the author again.

> Is there something like tex2texinfo ?

No.
For now it is not worth the effort anyway, I think.

	Bernhard

---

From: Bernhard Reiter <[email-masked]>
Date: Wed, 17 Aug 2005 09:58:23 +0200

Am 17. Aug 2005 um 09:48:42 schrieb Bernhard Reiter:
> > Em Tuesday 16 August 2005 11:49, Bernhard Reiter escreveu:

> Maybe we can try contacting the author again.

Following up on Carleos info documented in here:
http://intevation.de/pipermail/statist-list/2004/000060.html

I found out that you can find 1.0.1 packaged at:
http://mentors.debian.net/debian/pool/main/s/statist/

We just need to find a Debian sponsor for
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=155073 . 

Maybe we can ask Carleos for help packaging the new version, too.

	Bernhard

---

From: Jakson Aquino <[email-masked]>
Date: Wed, 17 Aug 2005 05:58:44 -0300

Hi Bernhard,

I don't know very much about building binary packages. I just 
copyied the i386 from the original script. It worked here, 
but might cause problems somewhere.

> Maybe we can ask Carleos for help packaging the new

Could you please, try to contact him? The better that I can 
do is reading something, and add some new variables to the 
control file. Much better would be if the package was built 
by someone with experience. Of course we don't need the 
binaries to release statist. We can add them later. 
Alternatively, we add the binaries and replace them latter. 
Since Statist is a simple program, I think that the binaries 
will work in most computers.

Best,

Jakson

---

From: Bernhard Reiter <[email-masked]>
Date: Wed, 17 Aug 2005 11:32:45 +0200

Hi Jakson,

> but might cause problems somewhere.

Debian will have instructions.

> Could you please, try to contact him? 

If you wish, I will write him an email and copy the list.

> will work in most computers.

Yes, I agree.
I run it on ppc with GNU/Linux without problems.

	Bernhard

---

From: Jakson Aquino <[email-masked]>
Date: Wed, 17 Aug 2005 16:57:20 -0300

Hi Bernhard,

> If you wish, I will write him an email and copy the list.

I made some improvements in the script. But I think that it 
still not fulfilling all prerequisites for being accepted by 
Debian people as an official Debian package. It would be 
good to find someone to improve it.

Best,

Jakson

---

From: Carleos Artime <[email-masked]>
Date: Thu, 29 Sep 2005 22:58:22 +0200

> good to find someone to improve it.

Hi all!

First, sorry for taking so much time to answer.  I'm very busy now,
like all of you, I suppose...

1. I have not used "statist" for a long time.  But building the Debian
   package was quite easy, becauses it uses GNU tools (configure & make).

2. I just received a message, that my ITP (intent to package) to Debian
   is closed, because it was too old and no Debian developer was 
   interested in it.  Sure it helped that I did not continue to build
   packages for the new versions.  See http://bugs.debian.org/155073

3. If there is an interest, I can "reopen" that "bug" and try to build
   the new "statist".  I remember that last time we discussed whether there
   should be a German or English version by default.  By following this
   list, I presume that gettext support was improved thereafter, and now
   packaging "statist" should be even easier.

Cheers,
 
-- 

_________________________________________________________________________

 Carlos Enrique Carleos Artime                            ,  GNU.org  , 
 Dep-to de Statistiko kaj Plejbonigiko,                  /             \ 
           kaj Matematika Didaktiko                     ((__-^^-,-^^-__)) 
 Universitato de Oviedo                                  `-_---' `---_-' 
                                                          `--|o` 'o|--' 
 Retposhto: [email-masked]                                \  `  / 
 Telefono:  +34 985 181 904                                   ): :( 
 Fakso:     +34 985 181 902                                   :o_o: 
 Adreso: Escuela de Peritos, 33203 Hispanio                    "-"

---

From: Bernhard Reiter <[email-masked]>
Date: Fri, 30 Sep 2005 02:27:32 +0200

Hi Carleos,

> like all of you, I suppose...

no problem, it is good to read you now!

>    package was quite easy, becauses it uses GNU tools (configure & make).

What was the reason for not using it?
Especially: Can we make you a user again?

>    the new "statist".  

It is Jakson's say, but I'd say: Go ahead!

>    I remember that last time we discussed whether there

Yes, Jakson completely enabled gettext, so Statist is completely
internationalised.

Best,
	Bernhard

---

From: "Jakson A. Aquino" <[email-masked]>
Date: Fri, 30 Sep 2005 09:08:02 -0300

Hi Carleos, and Berhard,

I'm glad that Carleos might build the Debian package.
Although I have made it for release 1.3.0, it really
wasn't following Debian rules, and I still don't know how to
make it correctly.

Thanks Carleos!

Best,

Jakson