Subject: news in the cvs

From: Jakson Aquino <[email-masked]>
Date: Wed, 13 Jul 2005 00:23:25 -0300

Hello All,

Bernhard give me write access to cvs, and I made
some changes in the Statist sources and
documentation. The po files were also updated.

The changes are registered in the file CHANGES,
and, the majority of them already were discussed
in this list.

In the new code that I wrote, the messages that
should be in German are in English.

Regarding the documentation, I replaced the
boxplot-en.png with boxplot-en.fig because it's
easier to translate to other languages (I'll
translate the manual into Portuguese). But now,
pdflatex isn't including the picture in the
final pdf file. Thus, I used dvipdfm, which is
part of teTex package.

I put the pdf files into the cvs because I think
that some users might not have teTex and xfig
installed, and these packages are necessary to
compile the pdf files. I also added a Makefile
to compile the pdf files.

Comments, suggestions, bug reports etc...
are welcome!

Best,

Jakson

_______________________________________________________ 
Yahoo! Acesso Grátis - Internet rápida e grátis. 
Instale o discador agora! http://br.acesso.yahoo.com/

---

From: Bernhard Reiter <[email-masked]>
Date: Wed, 13 Jul 2005 12:11:31 +0200

Hi Jaskson,

> documentation. The po files were also updated.

very nice.

> should be in German are in English.

Can you post an overview, then maybe sombody can help with the translation.

> boxplot-en.png with boxplot-en.fig 

Personally I prefer Skencil (www.skencil.org) over xfig these days. 
Skencil can read .fig files.

> because it's
> final pdf file. 

As far as I know you need to have an .eps and then
use epstopdf to make a figure go best with pdflatex.
Or use .png for images.

> to compile the pdf files.

Usually I refrain from putting non-sources into the CVS,
as they sometimes get out of sync.
Especially if developers do not have the necessary tools.
(Probalby only transfig.)
This is different from a tarball where a pdf should be included.
We could also directly offer a pdf manual for download somewhere.

Thanks for the great work you are putting into statist!
	Bernhard

---

From: Jakson Aquino <[email-masked]>
Date: Fri, 15 Jul 2005 01:20:13 -0300

Hi Bernhard,

> help with the translation.

Basically, new messages were added at the end of data.c
and in the file recode.c. They are related with the
new features: extract columns from fixed width data
file, extract sample of rows and recode. I didn't
change the original messages. But I also added to
gettext two or three strings that were only in German
(because they were the same in both languages), and in
two places I replaced "data set" with "sample".

The translator have only to seek for the word "fuzzy"
in the po file and also look for untranslated
messages. A tool like kbabel can be helpfull because
it can show only unstranlated and fuzzy message, and
it allows the user to do a spell check in the
translated messages only. Emacs has a po mode, but I
don't know what its feature are. But perhaps we should
plan a new release of Statist before translanting the
new strings. The translations should be the last step
before the release. I already made the Portuguese
translation of the strings, but I'm aware that the
English strings still might be changed.

> Personally I prefer Skencil (www.skencil.org) over
> xfig these days. Skencil can read .fig files.

I didn't know Skencil. I'll try it.

> use epstopdf to make a figure go best with pdflatex.

I didn't have the idea of using epstopdf. I'll test it.
The nice thing about dvipdfm is that it creates
hyperlinks in the pdf document, and after the creation
of the dvi file with latex, it's very fast the
conversion into pdf.

> Usually I refrain from putting non-sources into the
> CVS, as they sometimes get out of sync.
> Especially if developers do not have the necessary
> tools. (Probalby only transfig.)
> This is different from a tarball where a pdf should
> be included. We could also directly offer a pdf
> manual for download somewhere.

We can remove the pdfs, but where will we maintain the
pdf files for download? Perhaps we should maintain the 
pdf files in the cvs only untill the release of the 
next tarball, and, then, remove them from the cvs...

Best,

Jakson

---

From: Bernhard Reiter <[email-masked]>
Date: Fri, 15 Jul 2005 10:06:10 +0200

Hi Jakson,

Am 15. Jul 2005 um 01:20:13 schrieb Jakson Aquino:
> But perhaps we should
> before the release. 

yes, this is a good strategy.

As for .po tools, there is also www.poedit.org.

> of the dvi file with latex, it's very fast the

I think pdflatex will also create hyperlinks, 
if you used the right LaTeX package.

> pdf files for download? 

As mentioned before, I will offer a new infrastructure for statist soon
that will have place for stuff to put online. 
Currently I can put it in the same place as statist releases.

> Perhaps we should maintain the 

I'd rather not have them in CVS.
Shall I place the pdf somewhere for downloading?

	Bernhard

---

From: Jakson Aquino <[email-masked]>
Date: Fri, 15 Jul 2005 12:02:45 -0300

Hi Bernhard,

> if you used the right LaTeX package.

I have to solve some dependency problems to install
Skencil, before trying to re-writte the doc/Makefile.
But, if you prefer, you can change the Makefile and
the manual-en.tex as necessary now.

> Shall I place the pdf somewhere for downloading?

Sure! You can remove the pdf files from the CVS and put
them in another place. The new infrastructure for
Statist is very promising! Will it have space for
forums in laguages other than English? Some users
might want to contribute comments, bug reports, or
usage tips, but not be confortable writting in
English.

Best,

Jakson

---

From: Bernhard Reiter <[email-masked]>
Date: Mon, 18 Jul 2005 15:12:09 +0200

Hi Jakson,

> the manual-en.tex as necessary now.

No problem, take your time.
If you have Skencil problems, ask on their list,
I am also reading there from time to time.

> them in another place. 

Will do so, but might take me a few days.

> The new infrastructure for

It will be a regular Gforge, I'll have to check if
there is space for other language, but probably we can
arrange something. We just need a responsible person
for each language that we do not speak.

	Bernhard