Subject: bug in Makefile?

From: Carleos Artime Fi <[email-masked]>
Date: Mon, 11 Mar 2002 13:12:39 +0100

Hi. In statist-1.0.1, tests/Makefile, this line appears:

	test -z "$(CLEANFILES)" || rm $(CLEANFILES)

which, in my Debian 2.2r5 produces an error, because "test" returns 1 if
true and 0 if false, and "bash" executes the command after || if
success (0) and does not if failed (not 0).

Am I wrong?

On the other hand, I would like to know if there has been any attempt to
build a Debian package of "statist" (a .deb file). Anybody knows?

Cheers.

Carlos Carleos

---

From: Bernhard Reiter <[email-masked]>
Date: Mon, 11 Mar 2002 19:21:00 +0100

> success (0) and does not if failed (not 0).

The rm will be executed when the "$(CLEANFILES)" is not empty.
This seem to be correct to me.

In my bash I can try the following:

   test -z hi || echo hi
hi
   test -z || echo ho

This is because test -z returns 0 if the string is empty.
Hmm no idea why this would produce an error.

> build a Debian package of "statist" (a .deb file). Anybody knows?

I am not aware of debian packaging attempts.
It would be appreciated, though.  :)

	Bernhard

---

From: Carleos Artime Fi <[email-masked]>
Date: Tue, 12 Mar 2002 21:42:50 +0100

> Hmm no idea why this would produce an error.

Sorry! I misunderstood the behavior of "test". 
The problem must be some conflict between statist's Makefile and
Debian tools for package building. I will try anew and tell you the
results.

carlos

---

From: Carleos Artime Fi <[email-masked]>
Date: Thu, 16 May 2002 20:15:36 +0200

Hi!

This is my first attempt to build Debian packages of "statist". 
You may access this anonymous ftp server:
	ftp://fisher.ciencias.uniovi.es/pub/statist
and try it out (i386 binaries).

If no bugs are found, my intention is that statist be included
in the main section of Debian in a near future...

All the best.

carlos

PS: For any problem, please e-mail carleos @ fisher.ciencias.uniovi.es.

---

From: Bernhard Reiter <[email-masked]>
Date: Fri, 17 May 2002 11:18:35 +0200

Carleos,

this is good news!

Can you also make the .src.deb available somewhere?
The good part about Debian is, that it runs on many
hardware platforms. :)

About the language issue, wouldn't it be more suitable to 
give to give the packages different names.
Especially if we manage to do a gettext version sometime in the
future? 

E.G. like:

statist-de-..
statist-en-..

Thanks for sharing your work,
	Bernhard

---

From: Bernhard Reiter <[email-masked]>
Date: Thu, 10 Jun 2004 22:27:45 +0200

> Can you also make the .src.deb available somewhere?

Hi Carleos,
did you actually publish this somewhere?

Best,
	Bernhard

---

From: Bernhard Reiter <[email-masked]>
Date: Mon, 14 Jun 2004 12:00:37 +0200

Carleos,

yes, that answered my questions!
I never saw the necessary debian files for building the packages.
Probably I should place them in the CVS.

	Bernhard

On Fri, Jun 11, 2004 at 10:59:16AM +0200, Carleos Artime wrote:
> Je 2004-06-10-22-27-45 (+0200), Bernhard Reiter skribis:
> Looking for "statist" in http://www.apt-get.org/main/ gives the 
> location of binaries and source packages (unofficial) for Debian.
> Directly: ftp://fisher.ciencias.uniovi.es/debian/unstable/main/source/
> 
> Recall that Debian has not .src.deb, but .orig.tar.gz is the
> original source file, and .diff.gz is the corresponding patch.
> 
> I have registered "statist" as an "intent to package":
> 	http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=155073
> Now I have to find a "sponsor" to get it into Debian as an
> "official package".
> 
> I'm not sure I'm answering your question.