Subject: release schedule

From: Jakson Aquino <[email-masked]>
Date: Fri, 22 Jul 2005 07:09:29 -0300

Hello All,

I'm presenting here a proposal of release schedule.

I added new features to Statist, and the new version
could be 1.1.0. However, I plan to add some new
features on next months, and, I think we could release
the next version as 1.0.2, waiting for the new
features to release the (still unstable) version
1.1.0.

I propose the following schedule:

01 Aug - Deadline for tests, bug fixes, string changes,
                and documentation writting. Strings are
                ready for translation.
08 Aug - Translation deadline.
15 Aug - Release of Statist 1.0.2.

Because some users might not have all the necessary
tools, in addition to what we have in the cvs, I think
that the Statist tarball should have the .gmo files in
the po directory and the pdf files in the doc
directory.

I plan to translate the Statist manual into Portuguese,
and I'll do that after 01 Aug.

Is the proposed schedule OK? Did I miss any step or are
the dates inadequate?

Best,

Jakson

_______________________________________________________ 
Yahoo! Acesso Grátis - Internet rápida e grátis. 
Instale o discador agora! http://br.acesso.yahoo.com/

---

From: Bernhard Reiter <[email-masked]>
Date: Fri, 22 Jul 2005 18:31:09 +0200

Hi Jakson,

Am 22. Jul 2005 um 07:09:29 schrieb Jakson Aquino:
> could be 1.1.0. 

I wonder if statist should adopt a licensing schema like Linux,
with 1.odd. be development and 1.even. be stable releases.

> However, I plan to add some new

To have internationalisation in place
would warrant a 1.2.0 release, too
as this is a bigger step.

> 15 Aug - Release of Statist 1.0.2.

Fine with me, I will not have much time to help,
so how could I be against the schedule? :)

> the po directory and the pdf files in the doc directory.

Sounds good.

	Bernhard

---

From: Jakson Aquino <[email-masked]>
Date: Sat, 23 Jul 2005 11:39:27 -0300

Hi Bernhard,

Em Sex 22 Jul 2005 13:31, Bernhard Reiter escreveu:
> I wonder if statist should adopt a licensing schema
> like Linux, with 1.odd. be development and 1.even.
> be stable releases.
>

What version number do you think is more adequate,
1.1.0 or 1.2.0?

I tested many items of Statist menu, and they
don't seem to have problems. However I don't know 
what kind of data would be necessary to run
some analyses (like probit), and thus, I can't
guarantee that the graphics are really working with
gettext in these functions. On the other hand, I
believe that we have no bugs in the statistical
results, and this is the most important thing to
consider Statist stable. I'll be happy with any
version number :-)

Best,

Jakson

---

From: Bernhard Reiter <[email-masked]>
Date: Mon, 25 Jul 2005 12:29:12 +0200

Hi Jakson,

1.2.0 for the step to internationalisation
and 1.3.x for your development items.

> consider Statist stable. I'll be happy with any

I am merely voicing ideas here.
You are in the driving seat.

	Bernhard