Subject: change statist behavior? (y/N)

From: "Jakson A. Aquino" <[email-masked]>
Date: Wed, 23 Nov 2005 05:56:44 -0200

Hi,

When the user has a question of the type (y/N), he must
choose "y" explicitly to answer "yes". This is ok, because
other software with text interface do the same (example:
apt-get). However, unlike apt-get, statist aborts the
operation if the user just press <Enter>. I think that
considering a <Enter> as "No" would be more intuitive.

I have no strong preference for the new proposed behavior,
and I would like to know what more experienced users of
Linux and Unix think is the best behavior.

Best,

Jakson

---

From: Bernhard Reiter <[email-masked]>
Date: Thu, 24 Nov 2005 14:29:19 +0100

> considering a <Enter> as "No" would be more intuitive.

I think it is fine, if the default action will be choosen if
<Return> is hit. In the case of "(y/N)" this should be the answer "no".