Subject: translating German comments

From: Jakson Aquino <[email-masked]>
Date: Sat, 2 Jul 2005 05:42:41 -0300

Hello all!

I'm trying to translate some German comments (not
the messages) that are in the source code to make
it easier for people who don't speak German
(including myself) to understand the code.

Please, could anyone revise the following
translations? The lines below were extracted from
a patch generated with diff, but you can correct
them directly in a reply to this email, and  I'll
apply the changes.

Thank you!

Jakson

menue.c
@@ -55,12 +55,13 @@
- - Prueft, ob Spalten unterschiedliche Laenge besitzen
+ Test whether columns have different lengths

====================================================================

procs.c
@@ -45,8 +45,8 @@
- -   berechnet partielle korrelation; maximal 3 feste 
korrelationen
+   calculate partial correlation; at most 3 constant 
correlations

@@ -777,7 +779,7 @@
- - Test auf gleiche Effektwahrscheinlichkeiten bzw. 
gleiche Dosen
+ Test on same effect-probability as well as same dosis

@@ -1612,7 +1614,7 @@
- - kritische Werte fuer 95% Konfidenzinterval des 
Medians aus NEAVE:
+ critical values for 95% confidence interval of the 
Medians (see NEAVE):

@@ -1784,8 +1786,8 @@
- - kritische roh-Werte fuer signifikanzniveaus 1%, 2%, 
5% und 10%  fuer n<=30
- - indizes (zweiseitig!), gilt erst ab n >= 5! (Aus 
SACHS, S. 230)
+ critical roh-Values for significance levels 1%, 2%, 
5% and 10% for n <=30
+ indexes (bilateral!), is valid only for n >= 5! (in 
SACHS, p. 230)

@@ -1883,7 +1885,7 @@
- - t-Test auf Differenz zweier Mittelwerte aus zwei 
Stichproben
+ t-Test of difference between two median values from 
two data sets

@@ -1940,8 +1942,7 @@
- - t-Test auf Differenz zweier Mittelwerte aus zwei 
paarweise erhobenen
Stichproben
+ t-Test of difference between two median values from 
two paired data sets

====================================================================

statist.h
@@ -64,23 +64,22 @@
- - #define MPOLY 20     /* maximaler Grad des Polynoms
+ #define MPOLY 20     /* Maximum degree of polynomials

- -#define MLINE 255    /* Max. Zeichen fuer 
Standard-Zeilenvariable
+#define MLINE 255    /* Maximum number of chars for 
standard line variable

_______________________________________________________ 
Yahoo! Acesso Grátis - Internet rápida e grátis. 
Instale o discador agora! http://br.acesso.yahoo.com/

---

From: Bernhard Reiter <[email-masked]>
Date: Mon, 4 Jul 2005 11:25:49 +0200

Hi Jakson,
not reading the code around it, but the comments,
here are some remarks.
Note that the optimal result would be that the code is understood
before the comment is translated as the comment might as well be not
100 acurate. ;-)

On Sat, Jul 02, 2005 at 05:42:41AM -0300, Jakson Aquino wrote:
> menue.c
> @@ -55,12 +55,13 @@
> - Prueft, ob Spalten unterschiedliche Laenge besitzen

Literally translated it would be "Tests", but I do not think this matters.
ok.

> -   berechnet partielle korrelation; maximal 3 feste 
> korrelationen

ok.

> @@ -777,7 +779,7 @@
> - Test auf gleiche Effektwahrscheinlichkeiten bzw. 
> gleiche Dosen

ok.

> 
> @@ -1612,7 +1614,7 @@
> - kritische Werte fuer 95% Konfidenzinterval des 
> Medians aus NEAVE:

ok.

> @@ -1784,8 +1786,8 @@
> - kritische roh-Werte fuer signifikanzniveaus 1%, 2%, 
> 5% und 10%  fuer n<=30
> - indizes (zweiseitig!), gilt erst ab n >= 5! (Aus 
> SACHS, S. 230)

"roh" means "raw"

> + indexes (bilateral!), is valid only for n >= 5! (in 

ok.

> 
> @@ -1883,7 +1885,7 @@
> - t-Test auf Differenz zweier Mittelwerte aus zwei 
> Stichproben

I believe that median != average,
and "Mittelwert" mean "average". "Mittelwerte" is plural.

"Stichproben" means "samples", though "data set" is not wrong of course.

> @@ -1940,8 +1942,7 @@
> - t-Test auf Differenz zweier Mittelwerte aus zwei 
> paarweise erhobenen
> Stichproben

See remarks to the last translation.

> - #define MPOLY 20     /* maximaler Grad des Polynoms

"des polynoms" is singular possesive, but I think this does not matter.

> -#define MLINE 255    /* Max. Zeichen fuer 
> Standard-Zeilenvariable

ok.

	Bernhard

---

From: Jakson Aquino <[email-masked]>
Date: Mon, 4 Jul 2005 10:57:45 -0300

Hello All!

Bernhard: thanks for the corrections!

Michael Gebhardt also revised the translations and he 
too suggested that "data set" was replaced with 
"sample". Should I make the replacement also in the 
English messages that are shown to users?

Best,

Jakson

---

From: Bernhard Reiter <[email-masked]>
Date: Mon, 4 Jul 2005 18:22:26 +0200

Hi Jakson,

> English messages that are shown to users?

Yes, why not, if you also feel that it is appropriate. :)
	Bernhard