Subject: colors

From: "Jakson A. Aquino" <[email-masked]>
Date: Sun, 13 Nov 2005 21:22:57 -0200

Hello all!

I'm developing a color scheme for statist. The use of colors
will be optional. The color must be activated by either a
command line option (--color) or an option in the
preferences file (statistrc: color = yes). Below is what I
added to my ~/.statistrc. I also attached to this mail a
html file with the resulting output of using this color
scheme. So far my creativity was only enough to use 5
colors. Any suggestion of a different color scheme is
welcome.

Best,

Jakson

# file: ~/.statistrc:

# Color scheme. The color names have the format
# <attribute><color>, where the attribute part of the name
# is optional, and might be "bright", "dim", "blink" or
# "underln"; and the colors might be "red", "yellow",
# "green", "blue", "cyan", "magenta", "white", or "black".
# Warning: "dim", "blink", and "underln" might not work as
# expected in some terminal emulators. 

cl_error = brightred
cl_instructions = yellow
cl_headers = brightwhite
cl_menu_separator = blue
cl_line_num = magenta

---

From: Bernhard Reiter <[email-masked]>
Date: Wed, 16 Nov 2005 14:41:45 +0100

Am 13. Nov 2005 um 21:22:57 schrieb Jakson A. Aquino:
> will be optional. 

Good idea.
Make sure that it will not contain vital information as many people
cannot distinquish colors.

Note that it probably is hard to get this right in a compatible way,
because all the different terminal capabilities.

	Bernhard

---

From: "Jakson A. Aquino" <[email-masked]>
Date: Thu, 17 Nov 2005 05:00:00 -0200

> cannot distinquish colors.

OK! I'll not add any feature that depends on colors. And the
colors are really optional. They must be explicitly
activated.
 
> because all the different terminal capabilities.

Yes, I only know to produce colors in the GNU/Linux terminal
emulators, and I don't think that colors are really
important. I only added them to make the output more funny.

Best,

Jakson